Savage hunt loading to Black screen

  • Got a new laptop since the other one decided that the network card was going to bite the dust and decided to play DP again. So started my install of the games ... SH first and things gave me problems so stopped for a couple months and came back yesterday and tried again and things went better got it to download and install from the website however.. (yes i have it set to admin and compatability before you ask) when

    I start the game it goes through the gamigo and runewalker splash screens and then black screen nothing else but I hear the fire place or fire sound in the background. Please Note this computer can run WoW (with tons of addons), and StarWars the Old Republic Both on High Res so it should be able to run this as well. It also runs Neverwinter Online and Ulitma Online so that gives you a wide range of games and resolutions to choose from.

    So if anyone has any ideas please let me know... While you guys are thinking I'll start the install on DP and pray it doesn't do the same thing oh and yes i even tried removing the dragoon folder and starting the game again.

  • does this not do a regular type of install? because for some reason even though i am the admin of my new computer it won't let me extract this to anywhere but my desktop or the downloads section. And of course it is still doing that now. for savage hunt haven't even gotten to dp which i have both of the zips down loaded